pkg_resources.ContextualVersionConflict 问题

在上传自己的包到pypi的时候,碰到了一个错误:

1
pkg_resources.ContextualVersionConflict: (idna 2.8 (/home/kevin/.local/lib/python3.6/site-packages), Requirement.parse('idna<2.7,>=2.5') {requests}

这个错误的原因是requests库使用的idna库的版本过低。解决方法是降低idna版本或者升级requests版本即可。

你的支持我的动力