Ubuntu 安装软件遇到 Unmet Dependences错误

安装tree 命令时碰到

1
2
3
4
5
6
7
8
9
10
11
12
The following packages have unmet dependencies:
appmenu-qt : Depends: libdbusmenu-qt2 but it is not going to be installed
apturl : Depends: adwaita-icon-theme but it is not going to be installed
avahi-daemon : Depends: libavahi-core7 (>= 0.6.24) but it is not going to be installed
checkbox-converged : Depends: qtdeclarative5-test-plugin but it is not going to be installed
cups : Depends: libcups2 (= 2.1.3-4) but it is not going to be installed
cups-browsed : Depends: libcups2 (>= 1.7.0) but it is not going to be installed
cups-bsd : Depends: libcups2 (= 2.1.3-4) but it is not going to be installed
cups-client : Depends: libcups2 (= 2.1.3-4) but it is not going to be installed
cups-core-drivers : Depends: libcups2 (= 2.1.3-4) but it is not going to be installed
cups-daemon : Depends: libcups2 (= 2.1.3-4) but it is not going to be installed
....

缺少必要的依赖 或是当前安装的依赖版本过低。
解决方法:

1
apt-get -f install