Centos 7.2 安装Odoo Error Package nodejs-6.11.1的问题

在Centos7.2上安装Odoo 10的过程中出现了如下的问题:

1
2
3
4
5
6
Error: Package: 1:nodejs-6.11.1-1.el7.x86_64 (epel)
Requires: libhttp_parser.so.2()(64bit)
Error: Package: 1:nodejs-6.11.1-1.el7.x86_64 (epel)
Requires: http-parser >= 2.7.0
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

解决方案: root用户登录执行

1
rpm -ivh https://kojipkgs.fedoraproject.org//packages/http-parser/2.7.1/3.el7/x86_64/http-parser-2.7.1-3.el7.x86_64.rpm && yum -y install nodejs